В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hyihy
hyihy
28.09.2021 19:07 •  Информатика

For k: =1 to n do напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется чётное число. количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число - максимально чётное число.

Ответ:
sprikutviktpria
sprikutviktpria
23.09.2020 08:29
Program p12;
type tab=array[1..1000] of 1..30000;
var t:tab;
i,max,n:integer;
begin
readln(n);
for i:=1 to n do
readln(t[i]);
for i:=1 to n do
if(t[i] mod 2=0) and (t[i]>max) then max:=t[i];
write(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?