В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Паскаль, ? кто тут гений информатики? , ! написать программу и блок-схему дан массив из 10 целых чисел, заполненный генератором случайных чисел. найти минимальный элемент в массиве и подсчитать количество таких элементов в массиве.

Ответ:
98653240
98653240
23.09.2020 08:25
Program p12;
type tab=array[1..10] of integer;
var t:tab;
i,k,min:integer;
begin
min:=100;
for i:=1 to 10 do
t[i]:=random(10);
for i:=1 to 10 do
if(t[i]<min) then min:=t[i];
for i:=1 to 10 do
if(t[i]=min) then k:=k+1;
write('массив: ');
for i:=1 to 10 do
write(t[i],' ');
writeln;
writeln('Меньшее число ',min);
write('Количество меньших чисел ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?