В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anuar0403
anuar0403
27.06.2020 18:35 •  Информатика

Напишите программу в паскале "кодирование и декодирование информации" наподобие этой но больше примерно раза в три var a,c: string; i: integer; begin randomize; writeln ('введи фразу'); readln (a); c: =''; for i: =1 to length(a) do begin c: =c+a[i]+chr(random(32)+224); end; write (c); end.

Ответ:
10672
10672
30.08.2020 21:12
Const
    key = 3;

var
    i: integer;
    s: string;

function Encode(s: string; key: integer): string;
var
    i: integer;
begin
    for i := 1 to Length(s) do
        s[i] := chr(ord(s[i]) + key);
    Encode := s;
end;

function Decode(s: string; key: integer): string;
var
    i: integer;
begin
    for i := 1 to Length(s) do
        s[i] := chr(ord(s[i]) - key);
    Decode := s;
end;

begin
    write('Введите строку данных - ');
    readln(s);
    writeln('Выберите действие');
    writeln('1 - Закодировать');
    writeln('2 - Раскодировать');
    readln(i);
    case i of
        1: s := Encode(s, key);
        2: s := Decode(s, key);
    end;
    Writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?