В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anastasii03
Anastasii03
27.04.2020 21:11 •  Информатика

Написать программу: при вводе числа в двоичной системе нужно посчитать количество нолей и единиц а при вводе числа больше 1 будет выдавать error​

Ответ:
математик218
математик218
13.06.2020 15:40

На Python:

number = input('Введите число в двоичной системе счисления: ')

number_of_zeros = 0

number_of_units = 0

for i in number:

   if i == '0':

       number_of_zeros += 1

   elif i == '1':

       number_of_units += 1

try:

#    print('Введеное число: ' + str(int(number, 2)))

   print('Нулей: ' + str(number_of_zeros))

   print('Единиц: ' + str(number_of_units))

except ValueError:

   print('Error')

Объяснение:

закомментировал строку вывода числа в десятичной системе, если понадобится, можно раскомментировать (убрать #), если совсем не надо, можно удалить.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?