В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лена2222
Лена2222
27.11.2022 00:30 •  Информатика

Напишите программу, которая получает натуральные числа a и b(a меньше b) и выводит все простые числа в интервале от a до b

Ответ:
Вадим321566787654
Вадим321566787654
31.07.2020 17:21
PascalABC.NET 3.4.2, сборка 1933 от 01.04.2019

begin

 var (a, b) := ReadInteger2;  // Считывание a и b

 var simple := ArrFill(b + 1, true);  // Инициализация булевого массива значением true.

// Реализация решета Ератосфена

 for var i := 2 to b do

   if simple[i] then  

   begin

     var j := i * i;

     while (j <= b) do

     begin

       simple[j] := false;

       j += i;

     end;

   end;


 // Вывод на экран найденного результата

 for var i := a to b do

   if (simple[i]) and (i > 1) then i.Print

end.

0,0(0 оценок)
Ответ:
35gf467jh74944v
35gf467jh74944v
31.07.2020 17:21

var a,b,i,d,k:integer;

begin

write ('Введите натуральные числа a и b (a<b): ');

readln (a,b);

write ('Простые числа от ',a,' до ',b,': ');

for i:=a to b do

begin

for d:=2 to i do

if i mod d = 0 then k:=k+1;

if k=1 then write(i,'  ');

k:=0

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?