В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zhannayachmenev
zhannayachmenev
11.02.2020 21:08 •  Информатика

1.cоставить программу вычисления площади круга: s= п (пи)*r^2 2.cоставить программу вычисления площади треугольника: s=1/2*a*h 1) выделить целую часть результата. 2) выделить дробную часть результата 3) округлить результат 4) округлить до целого, не превосходящего рельтат 3. составить программу вычисления выражения: y=sin (a+b/2) при a=15, b=30 (градусов)

Ответ:
annajellycat
annajellycat
02.10.2020 10:50
Const n=3.1415;
var a, h, S, Rez: real;
begin
ReadLn(a);
ReadLn(h);
S:=a*h/2;
Rez:=trunc(S);  {отбрасываем дробную часть}
WriteLn(Rez);
Rez:=round(S); {выделяем целую часть}
WriteLn(Rez);
Rez:=frac(S);    {выделяем дробную часть}
WriteLn(Rez);
ReadLn;
end.

{Вопрос: в третьем задании до какой точности округлять??? }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?