Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
чссддпдппзжпжржо
19.06.2022 20:35 •
Информатика
Сработой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответ:
Тимофей225
03.10.2020 09:21
A) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
777Leha777
13.05.2022 12:05
5вопрос, желательно с полным решением...
ЯнаКиска
07.09.2022 10:29
Представьте число из двоичной системы счисления в десятичной1011→а10111→а1010101→а10100101→а1011→а101110101→а101101011→а10101011→а10решите ...
nastea3377
09.10.2021 11:36
Статья, набранная на компьютере, содержит 8 страниц, на каждой странице 40 строк, в каждой строке 64 символа. информационный объём ста-тьи составляет 25 кбайт. определите, сколько...
VladimirLK
16.07.2020 17:06
Создать алгоритм и написать программу позволяющую узнать считается ли вес человека нормальным. зная формулу вес=(рост(в см) *окружность грудной клетки(см)): 240...
lydmilagerasim
16.12.2021 18:01
Что такое c++, c# и python?подробнее расскажите, просто интересно....
jezv
17.05.2023 18:17
Составить программу для перевода сантиметров в миллиметры от 20 до 100 с шагом 5 (паскаль)...
Zod2141
11.06.2021 20:12
Для защиты растений от вредителей используют раствор барий хлорида.массовая доля раствора,полученного растворением 40г этой соли в 260г воды равна...
lizamrio1
28.11.2022 03:40
Спадкова хвороба, яка характеризується порушеннями в механізмах згортання крові: а) дальтонізм, б) гемофілія, в) синдром Дауна...
Panda2368
28.11.2022 03:40
Полина положила на вклад 60000 рублей на 1 год. При этом в договоре указана плавающая процентная ставка: в первые полгода процентная ставка составит 18 %, а во вторые полгода — 30...
лера1405
28.06.2021 20:52
Яке з двох тіл отримає більше прискорення при однаковій дії на них:ящик масою 25кг чи гиря масою 5кг...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.