В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Умник5001
Умник5001
20.02.2023 09:00 •  Информатика

Кто нибудь может написать программу транспонирования обычной матрицы из 9 чисел? заранее

Ответ:
inga50
inga50
03.10.2020 09:20
Const n=3;
var a:array[1..n,1..n] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходная матрица:');
for i:= 1 to n do
  begin
 for j:=1 to n do
  begin
  a[i,j]:=random(10);
  write(a[i,j]:4);
  end;
 writeln;
 end;
for i:=1 to n do
  for j:=i+1 to n do
 begin c:=a[i,j]; a[i,j]:=a[j,i]; a[j,i]:=c; end;
writeln('Транспонированная матрица:');
for i:=1 to n do
 begin
 for j:=1 to n do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходная матрица:
   1   4   4
   8   3   9
   8   2   1
Транспонированная матрица:
   1   8   8
   4   3   2 
   4   9   1
0,0(0 оценок)
Ответ:
olgagolova2007
olgagolova2007
03.10.2020 09:20
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
  // инициализация
  var b:=MatrixRandom(3,3,10,99);
  // вывод
  Writeln('Исходная матрица');
  for var i:=0 to 2 do begin
    for var j:=0 to 2 do Write(b[i,j]:3);
    Writeln
    end;
  // транспонирование
  for var i:=0 to 2 do
    for var j:=i+1 to 2 do
      if i<>j then Swap(b[i,j],b[j,i]);
  // вывод
  Writeln('Транспонированная матрица');
  for var i:=0 to 2 do begin
    for var j:=0 to 2 do Write(b[i,j]:3);
    Writeln
    end
end.

Тестовое решение:
Исходная матрица
 48 30 15
 38 49 19
 21 15 41
Транспонированная матрица
 48 38 21
 30 49 15
 15 19 41
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?