В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
WseNikiZanyati
WseNikiZanyati
06.10.2020 15:57 •  Информатика

Написать программу на паскале абс тема"работа с элементами одномерных массивов" создать два одномерных массива, состоящих из целых чисел. элементы массива вводятся с клавиатуры. в первом массиве найти номер первого элемента массива больше 5. во втором массиве найти первый нечетный элемент массива.

Ответ:
VafaMurad
VafaMurad
31.07.2020 17:16
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=5;

Var
 ar1,ar2:array[1..n] of integer;
 i,k,m:integer;
begin
 writeln('Reading array A:');
 for i:=1 to n do
 readln(ar1[i]);
 writeln('Reading array B:');
 for i:=1 to n do
 readln(ar2[i]);
 writeln('Res:');
 for i:=1 to n do
   if ar1[i]>5 then
    begin
     writeln(i);
     break;
    end;
  for i:=1 to n do
   if odd(ar2[i]) then
    begin
     writeln(ar2[i]);
     break;
    end;
end.

Пример ввода:
Array A:
1
2
4
5
9
Array B:
1
4
7
9
13
Пример вывода:
Res:
5
1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?