В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
2004тигр2004
2004тигр2004
08.07.2020 00:06 •  Информатика

Есть ли в массиве элементы, равные числу, введённому пользователем? паскаль. составить программу и оформить ответ!

Ответ:
aicha21
aicha21
03.10.2020 08:16
Var a: array[1..10] of real;
x: real;
a, i: integer;
begin
a:=0;
for i:=1 to 10 do begin
readln(a[i]);
if a[i] = x then 
a:=a+1;
end;
if a>0 then
writeln('Таких элементов ', a)
else
writeln('Такого элемента нет');
end.
0,0(0 оценок)
Ответ:
MyrkaPC325
MyrkaPC325
03.10.2020 08:16
Var 
a: array[1..100] of integer; 
i, j, c: integer;
begin 
Writeln('Массив '); 
for i := 1 to 100 do  begin   
a[i] := random(201) - 100;   
write(a[i], ' '); 
end; 
Writeln; 
write('Введите число (от -100 до 100) '); 
Readln(j); 
for i := 1 to 100 do    
if a[i] = j then begin c := c + 1; write(i, ' '); end; 
Writeln;   
if c>1 then write('В массиве число введённое вами есть в массиве и даже несколько (', c, '). Их индексы представлены выше') else  if c = 1 then write('Число, которое вы ввели есть в массиве. Его индекс представлен выше') else write('Такого числа в массиве нет');  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?