В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
НастяФем
НастяФем
20.08.2022 16:19 •  Информатика

Составьте программу вычисления площади кольца с внутренним радиусом r1 и внешним радиусом r2.значения r1 и r2 введите с клавиатуры

Ответ:
катя5089
катя5089
27.05.2020 21:08

Если твое кольцо есть фигура Тор, то это внешний и внутренний радиусы. (Внешний больше). Тогда код вот такой:

 

uses crt;
var
r1,r2: real;
begin
read(r1,r2);
writeln(pi*(r1*r1-r2*r2):0:3);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?