В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
илопор
илопор
25.12.2022 20:31 •  Информатика

Составить программу которая рассчитывает высоты проведенной к гипотенузе прямоугольного треугольника если известны его катеты значения катетов запрашиваются и вводятся с клавиатуры. ста

Ответ:
kirana05
kirana05
15.09.2020 19:21
Высоту можно определить по известной формуле (если проблемы с этим - см. Интернет или задайте вопрос в Геометрии, чтобы формулу вывели):
\displaystyle h:= \frac{ab}{ \sqrt {a^2+b^2}}, где a,b - катеты

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a,b:real;
  Write('Введите катеты через пробел: '); Read(a,b);
  Writeln('h=',a*b/sqrt(a*a+b*b))
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?