В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arsaeva73
arsaeva73
20.09.2022 23:46 •  Информатика

Напишите программу которая считывает 5 целых чисел определяет и печатает наибольшее и наименьшее из них

Ответ:
shakhzadinad
shakhzadinad
22.09.2020 01:24
Var a1,a2,a3,a4,a5,max: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1>a2) then max:= a1else max:=a2;
if (a2>a3) then max:=a2else max:=a3;
if (a3>a4) then max:=a3else max:=a4;
if (a4>a5) then max:=a4else max:=a5; 
  end;
writeln (max);
end. 
Аналогично с минимальным числом.
var a1,a2,a3,a4,a5,min: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1<a2) then min:= a1else min:=a2;
if (a2<a3) then min:=a2else min:=a3;
if (a3<a4) then min:=a3else min:=a4;
if (a4<a5) then min:=a4else min:=a5; 
  end;
writeln (min);
end.  
Можно так же решить с массива, если нужно пишите.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?