В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
милаха3451
милаха3451
06.01.2022 08:53 •  Информатика

Сделайте как в pascal только подробно за год квартплата повышалась дважды. первый раз на 30%, а второй на 40%. год назад семья платила квартплату, которая составляла 4500 тенге в месяц.напишите программу,посчитывающую сегодняшнюю квартплату семьи.

Ответ:
ruha20050420
ruha20050420
22.09.2020 00:00
Program as;
var a,b,c,d,e:real;
begin
writeln ('введите квартплату');
read (a);
b:=a*0.3; // узнаем 30% от суммы
c:=a+b; // получаем ответ после повышения на 30%
d:=c*0.4; //узнаем 40% от новой суммы
e:=c+d; // получаем конечный ответ
writeln('квартплата равна',e);
end.

если надо, можно ввести константу в размере 4500, тогда надо убрать рид.
0,0(0 оценок)
Ответ:
мдфв224
мдфв224
22.09.2020 00:00
Program kvart;
var k: real;
begin  
k:=4500; // известно что квартплата 4500
k:=k*1.3; //мы увеличиваем на 30 %
k:=k*1.4;  // новую квартплату мы увеличиваем ещё на 40 %
write(k); // выводим значение новой квартплаты
end.

Можно организовать ввод квартплаты тогда вместо строки k:=4500;
мы напишем readln(k);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?