В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
мейірімді
мейірімді
27.10.2022 16:26 •  Информатика

Заполнить массив (а) случайными целыми числами разных знаков. составить программу вывода на экран номеров элементов массива, равных максимальному. надо.

Ответ:
vasapipkin934
vasapipkin934
04.10.2020 18:48
Const n=10;
var a:array[1..n] of integer;
max,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
 a[i]:=random(21)-10;
 write(a[i],' ');
 end;
writeln;
max:=a[1];
for i:=2 to n do
 if a[i]>max then max:=a[i];
writeln('max = ',max);
for i:=1 to n do
 if a[i]=max then write(i:3);
writeln;
end.

Пример:
Исходный массив:
-6 -9 10 -6 0 0 -8 10 -8 2 
max = 10
  3  8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?