В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikysikkkkk
vikysikkkkk
20.07.2020 13:45 •  Информатика

Составьте программу в паскаль с while. стакан кипятка (100 °с) остыл за первую минуту на а градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. через сколько минут температура воды станет ниже nо с?

Ответ:
DanielB2008
DanielB2008
03.10.2020 06:15
Var A, gradus, minut, N: real;
Begin
Writeln('Введите A градусов');
readln(A);
Writeln('До какой температуры остужать:');
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
   A:=A*(1-0.15);
    gradus:=gradus-A;
    minut:=minut+1;
 end;

Writeln('Кипяток остынет до ',N,' градусов через ', minut, ' минут');
readln();
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?