В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NomD123
NomD123
21.04.2021 16:06 •  Информатика

Free pascal. нужно написать программу, где после каждой буквы ch вставляется строка str1.

Ответ:
вера571
вера571
03.10.2020 01:12
Var
  s,str1:string;
  ch:char;
  i:integer;
begin
  Write('Введите текст: '); ReadLn(s);
  Write('Введите искомый символ: '); Readln(ch);
  Write('Введите добавляемый текст: '); Readln(str1);
  for i:=Length(s) downto 1 do
    if s[i]=ch then Insert(str1,s,i+1);
  Writeln('Результат: ',s);
  Readln;
end.

Тестовое решение:
Введите текст: А роза упала на лапу Азора
Введите искомый символ: а
Введите добавляемый текст: 12345
Результат: А роза12345 упа12345ла12345 на12345 ла12345пу Азора12345
0,0(0 оценок)
Ответ:
vikysikkkkk
vikysikkkkk
03.10.2020 01:12
program Project4;
var ch:char; str,str1,str2:string; i:integer;
begin
    writeln('Введите исходный текст:');
    readln(str);
    writeln('Введите строку которую нужно вставить:');
    readln(str1);
    writeln('Введите символ после которого нужно вставить:');
    readln(ch);
    str2:='';
    i:=pos(ch,str);
    while i>0 do begin
      str2:=str2+copy(str,1,i)+str1;
      delete(str,1,i);
      i:=pos(ch,str);
    end;
    writeln('Результирующая строка: ',str2);
        readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?