Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
edshabashenko
31.03.2022 20:16 •
Информатика
Дан одномерный вещественный массив b(n). найти сумму положительных элементов массива
Ответ:
iltubaevapg
03.10.2020 04:37
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
var n:=ReadInteger('n=');
var b:=ArrRandomReal(n,-5,10);
Writeln('Исходный массив'); b.Println(', ');
Writeln('Сумма положительных элементов ',
b.Where(x->x>0).Sum)
end.
Тестовое решение:
n= 10
Исходный массив
6.62419754156107, 6.74697848816727, 4.73433683148322, -0.587218480923781, -4.4331698163567, 0.961155824345143, -0.229649536884227, 7.50758543494511, 7.66080652720332, 9.97409514848799
Сумма положительных элементов 44.2091557961931
0,0
(0 оценок)
Популярные вопросы: Информатика
tinapai
20.11.2021 07:09
Напиши программу Напишите функцию, которая вычисляет сразу максимальное и минимальное из трёх чисел. (Используйте изменяемые параметры.) Паскаль Очень нужно....
sofiika17
06.11.2022 06:32
Вкоробке лежит 256 карандашей среди них 16 красных. сколько информации несет сообщение о том ,что достали красный...
Tobirama0shok
11.12.2020 21:55
Напишите программу, которая в последовательности целых чисел определяет их сумму и подсчитывает разность количестваположительных и отрицательных чисел последовательности....
Лёха12339
02.01.2020 21:22
Написать программу, которая в последовательности целых чисел определяет их суммы и подсчитывает разность количества положительных и отрицательных чисел....
vika45584
02.01.2020 21:22
Вы не могли бы мне еще ? поезде нечетные места снизу а четные сверху. в одном купе едут алексей борис василий и григорий.укажите первые буквы имен юношей занимающих первое...
Сангали
24.07.2020 21:26
Скорость передачи данных по локальной сети 17 мбит в секунду. ученик перекачивал игру 19 минут. (это будет 2, 37 гб) сколько денег (в рублях) придется заплатить ученику за...
angelina20172
07.10.2020 18:03
Скласти 3 складні речення і підкреслити члени речення...
McMamon
25.11.2020 22:03
5. Какие цветы расколдовали Герху и напомнили ей о как? А) розы Б) фиалки: В) одуванчики. 6. Из-за какого подарка принца и принцессы Герда попала в плен к разбойникам? А)...
svetlanaastahov
27.10.2021 03:15
Как зовут девушку Гарри Поттера?...
set17
11.12.2020 13:20
Коротко опишіть завоювання Римом навколишніх територій. Які наслідки мала воєнна експансія Риму?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var n:=ReadInteger('n=');
var b:=ArrRandomReal(n,-5,10);
Writeln('Исходный массив'); b.Println(', ');
Writeln('Сумма положительных элементов ',
b.Where(x->x>0).Sum)
end.
Тестовое решение:
n= 10
Исходный массив
6.62419754156107, 6.74697848816727, 4.73433683148322, -0.587218480923781, -4.4331698163567, 0.961155824345143, -0.229649536884227, 7.50758543494511, 7.66080652720332, 9.97409514848799
Сумма положительных элементов 44.2091557961931