В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tobirama0shok
Tobirama0shok
11.12.2020 21:55 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет их сумму и подсчитывает разность количестваположительных и отрицательных чисел последовательности. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). программа должна вывести два числа: сумму чисел и разность количества положительных и отрицательных чисел.

Ответ:
Юлия757445
Юлия757445
05.10.2020 16:54
Program n1;
var sum,kp,ko,a: integer;
begin
readln(a);
sum:=0;
ko:=0;
kp:=0;
while a<>0 do
begin
sum:=sum+a;
if a>0 then kp:=kp+1
else ko:=ko+1;
readln(a);
end;
writeln(sum);
writeln(kp-ko);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?