В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lari133
lari133
25.09.2020 11:59 •  Информатика

Вмассиве храниться информация о стоимости товаров. составьте программу, которая определяет стоимость самого дешевого товара и его индекс.

Ответ:
roma34569
roma34569
23.05.2020 18:22

Массив данных о стоимости товаров зададим в виде целочисленных констант

program primer_1;
const a: array[1..12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58);
 i,min,k: integer;
 begin

min:=a[1]; 

for i:=2 to 12 do    if a[i]<min then

                                             begin 

                                              min:=a[i];
                                              k:=i;
write('минимальная стоимость ', min, '   индекс' ,k)
end.

Или скорее всего этот вариант

program primer_1;
var a: array[1..12] of integer;
i, min, k: integer;
begin
for i:=1 to 12 do read(a[i]);{Ввод стоимостей товаров}
min:=a[1];
k:=0;
for i:=2 to 12 do
if a[i]<min
then
begin
min:=a[i];
k:=i;
end;
write('мин. сто-мость ', min, ' индекс ' ,k)
end. 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?