В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilya3666664
ilya3666664
24.04.2020 07:24 •  Информатика

Составить программу на языке паскаль, для решения : 1".зная цену компьютера b рублей,определить хватит ли покупателю на a рублей купить компьютер? " 2."зная длину забора d метров,определить хватит ли сетки а метров.чтобы обнести этот забор"?

Ответ:
0AlikaLi0
0AlikaLi0
13.08.2020 15:33
1)
var
a,b,e:real;
begin
write('Сколько стоит компьютер - ');
readln(b);
write('Сколько денег у покупателя - ');
readln(a);
e:=a-b;
if e>0 then
 writeln('Покупателю хватит денег на покупку компьютера ценой - ',b,'руб.')
else
 begin
  e:=e*(-1);
  write('Покупатель не сможет купить компьютер ценой - ',b,'руб. Ему не хватает - ',e,'руб.');
 end;
end.
2)
var
a,b,e:real;
begin
write('Длина забора (м) - ');
readln(b);
write('Длина сетки (м) - ');
readln(a);
e:=a-b;
if e>0 then writeln('Сетки хватит чтобы обнести забор.')
else
 begin
  e:=e*(-1);
  write('Сетки не хватит чтобы обнести забор.');
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?