В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
M89226691130
M89226691130
02.08.2020 15:11 •  Информатика

Требуется вставить в данный массив на данное место данный элемент, сдвинув остальные элементы вправо.
Входные данные
В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. Во второй строке задаются N чисел – элементы массива (целые числа, не превосходящие по модулю 1000). В третьей строке вводится число, которое необходимо вставить, и номер места, на которое его нужно вставить.
Выходные данные
Вывести получившийся массив.
Примеры
Входные данные
5
1 2 3 4 5
2 3
Выходные данные
1 2 2 3 4 5

Ответ:
revati1
revati1
11.09.2020 18:56

C# 8.0:

using System;

...

public static void InsertToArr<T>(ref T[] Arr, in T Value, in int Index){

   T[] NewArr = new T[Arr.Length + 1];

   for (int i = 0; i < Index; i++) NewArr[i] = Arr[i];

   NewArr[Index] = Value;

   for (int i = Index + 1; i < NewArr.Length; i++) NewArr[i] = Arr[i-1];

   Arr = NewArr;

}

...

Console.ReadLine(); //skips N

var Arr =Array.ConvertAll(Console.ReadLine().Split(' '),int.Parse);

var temp = Console.ReadLine().Split(' ');

InsertToArr(ref Arr, int.Parse(temp[0]), int.Parse(temp[1])-1);

foreach (int i in Arr) Console.Write(i + " ");

0,0(0 оценок)
Ответ:
kostyaborisenk3
kostyaborisenk3
11.09.2020 18:56

===== PascalABC.NET =====

begin

 var n := ReadlnInteger;

 var a := ReadArrInteger(n);

 var (m, i) := ReadInteger2;

 a := a?[:i - 1] + Arr(m) + a?[i - 1:];

 a.Print

end.


Требуется вставить в данный массив на данное место данный элемент, сдвинув остальные элементы вправо
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?