В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Igor2000Petrov
Igor2000Petrov
03.05.2022 04:30 •  Информатика

Написать программу которая даст таблицу q5*5. каждый эелемент таблицы случайное число из отрезка [-30,+30]. вычислить сумму все отрицательных и сумму положительных элементов.

Ответ:
enotzdrt
enotzdrt
26.05.2020 22:51

var a,b,i,j,p,o: integer;
z:real;
m:array[0..31,0..31] of integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
begin
z:=random;
b:=random(31);
if z<0.5 then m[i,j]:=b;
if z>0.5 then m[i,j]:=-b;
end;
for i:=1 to 5 do
for j:=1 to 5 do
begin
if m[i,j]>0 then p:=p+m[i,j];
if m[i,j]<0 then o:=o+m[i,j];
end;
write(p,' ',o);
end.

 

мда. подумать над задачкой пришлось немного) но вот результат)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?