В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kostina68
kostina68
16.06.2022 12:10 •  Информатика

Составить в pascal с клавиатуры вводят строку. составить программу, которая: a) определит количество символов в ней; b) выведет на экран первый, второй и последний символы; c) выведет на экран коды первого и последнего символов строки; ∗ d) проверит, не ли первый и последний символы строки; ∗ e) определит количество символов в строке чётно или нечётно; ∗ f) проверит, есть ли в ней (в строке) слово «мама».

Ответ:
Поглит
Поглит
15.09.2020 11:48
// PascalABC.Net 3.0, сборка 1064
var
  s:string;
  n:integer;
begin
  Write('Введите строку: '); Readln(s);
  // a
  n:=Length(s);
  Writeln('Количество символов в строке равно ',n);
  // b
  Writeln(s[1],', ',s[2],', ',s[n]);
  // c
  Writeln(Ord(s[1]),', ',Ord(s[n]));
  // d
  if s[1]=s[n] then Writeln('Первый и последний символы совпадают')
  else Writeln('Первый и последний символы не совпадают');
  // e
  if n mod 2 = 0 then Writeln('Количество символов в строке четно')
  else Writeln('Количество символов в строке нечетно');
  // f
  if Pos('мама',s)>0 then Writeln('Строка содержит слово "мама"')
  else Writeln('Строка не содержит слово "мама"')
end.

Тестовое решение:
Введите строку: Тестовая строка со словом <мама> внутри
Количество символов в строке равно 39
Т, е, и
210, 232
Первый и последний символы не совпадают
Количество символов в строке нечетно
Строка содержит слово "мама"
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?