В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
markthebest95
markthebest95
18.06.2021 01:22 •  Информатика

Составить программу вычисления значения функции при любых х y ; = sin*(3.2+ (sqrt(1-x))/abs(5*x))

Ответ:
Диана8909
Диана8909
02.10.2020 22:55
// PascalABC.Net 3.0, сборка 1052
var
  x,y:real;
begin
  Writeln('Введите значение x: '); Read(x);
  if (x=0) or (x>1) then Writeln('Значение функции не определено')
  else begin
    y:=sin(3.2+sqrt(1-x)/abs(5*x));
    Writeln('Значение функции равно ',y)
  end
end.

Тестовое решение:
Введите значение x: 0.634
Значение функции равно -0.246679689801614
0,0(0 оценок)
Ответ:
OkumRin
OkumRin
02.10.2020 22:55
//sin* - это что-то новое, так что обойдёмся без умножения.
var x,y:real;
begin;
readln(x);
if (x=0) or (x>1) then
begin;
writeln('Ошибка');
exit;
end;
y:=sin(3.2+(sqrt(1-x))/abs(5*x));
writeln(y);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?