В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
DjYuLiAnNa
DjYuLiAnNa
14.01.2021 20:35 •  Информатика

Входные данные некоторый программы записаны в текстовый файл. в каждой строке файла содержится два целых и три вещественных числа, разделенные пробелами. напишите программу, которая выводит на экран сумму целых и сумму вещественных чисел из каждой строки.

Ответ:
юка28
юка28
30.07.2020 23:47
Var
  f:Text;
  i,j:integer;
  a,b,c:real;
begin
  Assign(f,'MyFile.txt');
  Reset(f);
  while not eof(f) do begin
    Read(f,i,j); Readln(f,a,b,c);
    Writeln(i+j,' ',a+b+c)
  end;
  Close(f)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?