В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Romabl4
Romabl4
18.10.2020 19:35 •  Информатика

Напишите программу, которая выводит все делители натурального числа, введенного пользователем с клавиатуры на питоне

Ответ:
1939345
1939345
26.05.2020 15:33

x=int(input())  #просим ввести число от пользователя

for i in range(1,x):#цикл который идет с 1 тк как делить на ноль нельзя и до числа не вкл его

 if x%i==0:#проверка на делимость

   print(i)#выводит результат

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?