Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
andrey1shpirko
17.02.2022 06:11 •
Информатика
Написать программу, которая считывает два числа a и б, и выдает б-тую цифру числа а! например: число 192345(а) число б = 3, тогда третяя цифра в числе 192345 равняется 2
Ответ:
allthesinners
29.07.2020 16:16
#include <stdio.h>
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %d\n",c[i]); //Вывод искомой цифры
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
1232964
14.04.2021 20:59
Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел,...
SkyZee
22.08.2020 04:42
Напишите наименьшее двузначное число, для которого истинно высказывание:НЕ(первая цифра чётная) И (число делится на 4)....
57494967468746
05.06.2023 22:00
Как кикнуть игрока на хайпиксель скайблок если он с тобой в коопе...
Ната911
15.03.2022 14:25
Какой объём памяти в байтах будет занимать следующий двоичный код: 00001110111100001101100111011101...
KseniaSob
10.12.2022 10:03
Напиши какие процедуры отвечают за вывод информации, очень нужно ( )...
evzhenko99
16.12.2022 14:54
Как выглядит пиктограмма Edit?...
IlonaBilash24
16.02.2022 10:26
Задай у вигляді оператора присвоювання таку дію: змінній а присвоїти значення середнього арифметичного змінних b, с і d. Познач у списку оператор, що реалізує цю дію: 1)a = b + c...
dimon564557
27.10.2022 05:42
Х = 4 y = 5 У консоль виведено такий рядок: х=4 у=5 х*у=20 Знайди оператора, який мав вивести цей рядок. 1) print ( x= , y= , x*y= ) 2) print (x, y, x*y) 3) print ( x= , x, y= ,y,...
lolipop101
12.01.2021 17:47
Программирование на Python дано натуральные числа m и n. Составить программу для нахождения всех их общих делителей...
fil2143878
17.10.2020 16:51
Написать сочинение -рассуждение на тему почему исчезают письма ? ? ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %d\n",c[i]); //Вывод искомой цифры
}
return 0;
}