В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lolipop101
lolipop101
12.01.2021 17:47 •  Информатика

Программирование на Python
дано натуральные числа m и n. Составить программу для нахождения всех их общих делителей

Ответ:
nutadobrenkaya
nutadobrenkaya
14.10.2020 09:15

Відповідь:

n = int(input("n = "))

m = int(input("m = "))

q = 0

p = []

while True:

   q += 1

   c = n%q

   d = m%q

   if c == 0 and d == 0:

       p.append(q)

   if q>m or q>n:

       break

print("Все общие делители - ", p)

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?