Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ярик471
08.02.2021 18:58 •
Информатика
Дан массив из 20 чисел заданных случайным образом. найти: наименьшее нечетное число и его номер. вывести на экран исходный массив, наименьший нечетный элемент и его номер.
Ответ:
WhiteFix
29.07.2020 09:59
Program znanija;
var A:array[1..20] of integer;
i,k,min,n:integer;
begin
min:=1000000000; // прощу прощение за такое )
for i:=1 to 20 do A[i]:=random(9); // заполняем массив
for i:=1 to high(A) do // находим минимальное нечётное, запоминаем его номер
if (A[i] < min) and (A[i] mod 2 <> 0) then begin
n:=i; min:=A[i];
end;
for i:=1 to 20 do write(A[i]:3); // Выводит весь массив
writeln(); // просто перевод на новую строку для красоты
writeln('Minimum: ',min,' Ego nomer: ',n); // выдаём минимальное и его номер
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Дончара
21.09.2020 02:48
Реферат на тему характеристики и устройство компьютера . заранее....
mariiiiii222
08.04.2022 15:41
По информатике 8 класс четыре девочки маша, таня, софия и полина пошли в кафе. какая из них покупала только один сок, причем две из них купили сок яблочный, одна...
yanasmailik
10.07.2022 11:40
Запишите число, которое будет напечатано в результате выполнения следующей программы: var s, n: integer; begin s := 0; n := 0; while 2*s*s 123 do begin s := s +...
nikarh
03.04.2021 09:07
Персональный компьютер - это.. Система, включающая подсистемы аппаратного обеспечения Подсистема системы человек-компьютер Средства взаимодействия человека и компьютера....
vovkahooligan
03.04.2021 09:07
Что такое система? * Реальный объект Сложный объект объект...
shaduraalya
02.07.2020 20:32
У меня странный во Недавно пропала кнопка *очистить кэш *.Марка телефона Самсунг А10. Все началось с того, что я скачала вирус,и с какого то озарения удалила.После...
8огонь8
04.09.2022 07:37
1. Закончите предложения. Функция ВЫБОР() ... .Функция ЕСЛИ() ..Функция СТРОЧН() ... .Функция Тип() Функция ПСТР() ... .2. Изучите ресурсы сети Интернет и предложитек...
ksutsydmi
27.06.2022 00:27
Составить программу для определения количества натуральных чисел из интервала от 100 до 500, сумма цифр которых равна 15...
Кирилл222123123413
04.06.2021 17:08
Как называется собственная(внутренняя) память человека?...
PRO11116
04.06.2021 17:08
Как с сосудов 3 и 5 литров отмерить 1 литр воды...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var A:array[1..20] of integer;
i,k,min,n:integer;
begin
min:=1000000000; // прощу прощение за такое )
for i:=1 to 20 do A[i]:=random(9); // заполняем массив
for i:=1 to high(A) do // находим минимальное нечётное, запоминаем его номер
if (A[i] < min) and (A[i] mod 2 <> 0) then begin
n:=i; min:=A[i];
end;
for i:=1 to 20 do write(A[i]:3); // Выводит весь массив
writeln(); // просто перевод на новую строку для красоты
writeln('Minimum: ',min,' Ego nomer: ',n); // выдаём минимальное и его номер
end.