В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Fefiego
Fefiego
30.08.2022 06:53 •  Информатика

Составьте программу, которая заполняет массив б(1..10) случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример вывода исходный массив : 10 2 4 1 3 5 7 8 количество пар чётных элементов = 2

Ответ:
ely4
ely4
26.05.2020 12:36

#include <iostream>

 

int main()

{

 int b[10];

 for(int i=0;i<10;i++)

 { 

  b[i]=rand()%10+1;

 }

 int a=0;

 for(int i=0;i<9;i++)

 {

  if(b[i]%2==0 && b[i+1]%2==0)

   a++;

 }

std::cout<<"Чётных пар: "<<a<<std::endl;

system("PAUSE");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?