В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mikstura71
mikstura71
10.05.2020 09:01 •  Информатика

Написать программу на языке паскаль . дан одновременный массив из п целых чисел .составить программу вычисления суммы элементов стоящих на четных местах

Ответ:
dianadidi3
dianadidi3
27.05.2020 17:58

var

M:array[0..100]of integer;

i,k,n:integer;

begin

k:=0

randomize;

write('введите кол-во элементов массива');

read(n);

for i:=1 to n do

begin

M[i]:=random (30);

if i mod 2 =0 then k:=k+M[i]

else write ('Четных элементов нет');

writeln ('Сумма четных элементов', k);

end;

end.

0,0(0 оценок)
Ответ:
sudak7
sudak7
27.05.2020 17:58

var

  a : array [1..1000] of integer;

  i, n, sum : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  sum := 0;

  for i := 1 to n do

    if i mod 2 = 0 then inc (sum, a[i]);

  writeln (sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?