В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
grek1990
grek1990
18.02.2023 08:03 •  Информатика

Составить программы pasсal 1) даны величины двух углов треугольника в градусах. составьте программу, которая определяет, существует ли такой треугольник. если да, то будет ли он остроугольным, прямоугольным или тупоугольным. 2)на плоскости xoy заданы своими координатами три не точки а(x1, y1), b(x2, y2) , и c(x3 , y3). составить программу, которая определяет, где расположена точка c ; выше, ниже или на отрезке ав.

Ответ:
Илий
Илий
02.10.2020 20:30
Первая задача
program firstProgram
var ug1, ug2: real;
begin
write("Введите первый угол: ");
read(ug1);
write("Введите второй угол: ");
read(ug2);
if ((ug1 + ug2) < 180)
begin
if ((ug1 > 90) or (ug2 > 90)) write("Треугольник тупоугольный");
else if ((ug1 = 90) or (ug2 = 90)) write("Треугольник прямоугольный");
else write("Треугольник остроугольный");
end
end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?