В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Evklidushka
Evklidushka
18.04.2020 20:08 •  Информатика

Напишите программу нахождения количества и суммы цифр целого положительного числа, используя для этого процедуру Sum(K, C, S), C - количество цифр целого положительного числа K, а S их сумма ( K — входной, C и S — выходные параметры целого типа).
Sample Input 1:
2651

Sample Output 1:
4 14

Sample Input 2:
67557

Sample Output 2:
5 30

Sample Input 3:
84717

Sample Output 3:
5 27

Ответ:
Cociheyuajnqhvedoxbs
Cociheyuajnqhvedoxbs
11.10.2020 12:37

program summa_i_kol_cifr;

var

x,s,k:integer;

begin

read(x);

s:=0;

k:=0;

while x>0 do

begin

s:=s+x mod 10;

k:=k+1;

x:=x div 10;

end;

write(k,' ',s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?