В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
жека12рус
жека12рус
23.07.2020 00:29 •  Информатика

Составьте программу , которая заполняет массив случайными целыми числами в диапозоне от 1 до 100 , затем меняет местами наименьший четный элемент с наибольшим нечетным элементом

Ответ:
Пиирмвп
Пиирмвп
26.05.2020 12:23

Program Pr1;
uses crt;
var mas:array[1..10] of integer;
i,max,min,a,b:integer;
Begin
clrscr;
max:=0;
min:=150;
randomize;
for i:=1 to 10 do mas[i]:=1+random(100);
for i:=1 to 10 do write(mas[i]);
for i:=1 to 10 do begin if (mas[i] mod 2=0) and (mas[i]>max) then begin
max:=mas[i];
a:=i;
end;
if (mas[i] mod 2=0) and (mas[i]<min) then begin
min:=mas[i];
b:=i;
end;
end;
i:=mas[a];
mas[a]:=mas[b];
mas[b]:=i;
writeln();
for i:=1 to 10 do write(mas[i]);
end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?