В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tsvakhvesna
tsvakhvesna
05.04.2023 09:27 •  Информатика

Напишите программу в паскаль abc, которая позволяют записать логические выражения, которые имеют значение «истина» когда: а) каждое из чисел a и b больше 100; б) только одно из чисел a и b четное; в) хотя бы одно из чисел a и b положительное.

Ответ:
TN02122002
TN02122002
28.07.2020 10:21
Var a,b:real;
l,f,j:boolean;
begin
f:=false;
read (a,b);
if (a > 100) and (b > 100) then l:=true else l:=false;
if ((a mod 2)=0) then f:=true;
if ((b mod 2)=0) then f:=true;
if ((a mod 2)=0) and ((b mod 2)=0) then f:=false
if a > 0 or b > 0 then j:=true else j:=false;
writeln ("а) ",l);
writeln ("б) ",f);
writeln ("в) ",j);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?