В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
belya84
belya84
17.09.2022 16:34 •  Информатика

Дан массив из 20 действительных чисел. напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. желательно подробную программу, буду всем )

Ответ:
mandarinka3001
mandarinka3001
27.07.2020 22:17
Var A:array[1..20]of real;
B,C:real;
i:byte;
Begin
WriteLn('Введи элементы массива через пробел');
For i:= 1 to 20 do
 Read(A[i]);
For i:= 1 to 20 do
 if A[i]>0 then B:=B+A[i]
 else C:=C+A[i];
WriteLn('Сумма положительных элементов = ',B);
WriteLn('Сумма отрицательных = ',C)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?