В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shakirqasanov
shakirqasanov
03.06.2023 22:50 •  Информатика

Составить программу ( паскаль) для 5 целых чисел, найти максимальное из них p.s только с if then else (должно быть коротко

Ответ:
sungatulin22
sungatulin22
27.07.2020 17:48
Var
n1,n2,n3,n4,n5:integer;
begin
Readln(n1,n2,n3,n4,n5);
If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then
writeln('Максимальное число: ',n1)
else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then
writeln('Максимальное число: ',n2)
else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then
writeln('Максимальное число: ',n3)
else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then
writeln('Максимальное число: ',n4)
else
writeln('Максимальное число: ',n5);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?