В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Gfgjlol
Gfgjlol
05.02.2020 02:15 •  Информатика

Спрограммой в паскале с процедуры процедура выводит n целых случайных чисел с интервала a, b

Ответ:
mariella25
mariella25
24.07.2020 22:00
Procedure RND(a,b,n:integer);
var
  i:integer;
begin
  Randomize;
  for i:=1 to n do Write(Random(b-a+1)+a,' ')
end;

var
  a,b,n:integer;
begin
  Write('Задайте интервал для генерирования чисел ');
  Read(a,b);
  Write('Укажите количество случайных чисел: '); Read(n);
  RND(a,b,n)
end.

Тестовое решение:
Задайте интервал для генерирования чисел -5 10
Укажите количество случайных чисел: 30
-4 1 4 -1 3 -4 9 1 5 -1 -1 9 1 -2 -5 -2 1 -2 2 -3 2 -4 7 10 -3 3 10 5 6 -1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?