Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
20H
16.07.2020 23:13 •
Информатика
Программа в паскале написать уменьшение положительного числа на 1 до тех пор,пока оно не станет отрицательным. как только число становится отрицательным,команда повторения заканчивает свою работу
Ответ:
veon1
02.10.2020 17:22
Var n:Integer;
Begin
Read(n);
while (n>=0) do
begin
n:=n-1;
end;
Writeln('Finished');
end.
0,0
(0 оценок)
Ответ:
Милан228
02.10.2020 17:22
var
a : integer;
begin
readln (a);
//Цикл с условием
//Он выполнятся пока верно его условие (a>=0)
While a >= 0 do
a := a - 1;
writeln (a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
maxradew
30.01.2023 15:45
Решить в паскаль составьте программу для вычисления суммы e^1+e^2+e^3+...
VLADBERYYYYYYY
10.12.2020 06:00
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной...
ANGELINA69Z
25.02.2020 03:47
Перечислите операции, отосящиеся к редактированию текста...
savdyut
25.02.2020 03:47
Впаскале. написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности действительных чисел. количество чисел должно задаваться во время...
kirill1s
01.09.2021 14:23
Запишите инструкцию, которая увеличивает на единицу значение переменной n....
hlagga
01.09.2021 14:23
Примеры обмена обработки и хранения информации...
dikray1
01.09.2021 14:23
Turbo pascal. определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 42; b : = 14; a : = a div b; b : = a*b; a : = b div a;...
sabitaiganym
01.09.2021 14:23
Можете доступно объяснить, как пользоваться схемой горнера на примере вот этого числа: 3204 в пятиричной системе счисления. а то я вроде бы понимаю, а вроде бы и нет : d...
alenaFox457
18.01.2021 05:12
Составте программу (паскаль) которая должна вычеслить прощадь поверхности целиндра по формуле s=2rh+2(r*r),радиус основания цилиндра(r)и высота(h)вводятся с клвиатуры! (если надо...
ivanovartem02
25.11.2020 23:21
Выполните умножение: а) 4x4(1 - x2); б) (a - 5)(1 + a)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Begin
Read(n);
while (n>=0) do
begin
n:=n-1;
end;
Writeln('Finished');
end.
a : integer;
begin
readln (a);
//Цикл с условием
//Он выполнятся пока верно его условие (a>=0)
While a >= 0 do
a := a - 1;
writeln (a);
end.