В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
savdyut
savdyut
25.02.2020 03:47 •  Информатика

Впаскале. написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности действительных чисел. количество чисел должно задаваться во время работы программы. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделено полу жирным шрифтом). вычисления среднего арифметического последовательности действительных чисел. найдите количество чисел последовательности -> 15. введите последовательность. после ввода каждого числа нажмите enter. -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифметическое введенной последовательности: 4.00 для завершения работы программы нажмите enter.

Ответ:
katelove8
katelove8
17.07.2020 18:17
Uses
  Crt;
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n);
  Write('Для завершения работы программы нажмите Enter');
  Readkey
end.

Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter

Для версии Pascal.ABC.Net:
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?