В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
batyademon
batyademon
05.06.2021 17:06 •  Информатика

Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем. б)написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

Ответ:
Wector11211
Wector11211
26.05.2020 06:38

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int number, counter = 0;
   float average = 0;

   cout << "Enter the number: ";
   cin >> number;

   //1)
   for(int i = 0; i <= number; i++)
   {
      average += i;
   }
   average /= (number + 1);

   //2)
   for(int i = 0; i <= number; i++)
   {
      if(i % 2 == 0) //Если чётное
      {
         counter++;
      }
   }

   cout << "Average = " << average << endl;
   cout << "The amount of even elements: " << counter << endl;

   return 0;
}


Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пол
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?