В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Нияз2014
Нияз2014
09.08.2022 16:57 •  Информатика

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс

Ответ:
12keti
12keti
24.07.2020 15:25
Const
  m=10;
  n=8;
var
  a:array[1..m,1..n] of integer;
  i,j:integer;
  p:double;

begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to m do
  begin
    for j:=1 to n do
    begin
      a[i,j]:=Random(101)-50;
      Write(a[i,j]:4);
    end;
    Writeln
  end;
  p:=1;
  for j:=1 to n do
      if a[3,j]>0 then p:=p*a[3,j];
  Writeln('Искомое произведение: ',p)
end.

Тестовое решение:
Исходный массив
  35  30  35 -25 -50   8 -20  47
 -34 -26  -7  34  -9 -31  10 -46
 -17 -21  27   8  27  41  35 -48
  30 -44  25  48  30 -20  10  -6
  -3 -10  45 -33   3 -38 -11  -8
  47 -25 -27  -7   2 -20  -4 -48
 -38  32 -29 -41  31  16  46  44
  45  33  -4  45  34 -18 -33  37
  15  49 -14 -49 -25  -8   1 -30
  41 -15  11   1  17  -8   0  -1
Искомое произведение: 8368920
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?