В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Маша2005051
Маша2005051
30.04.2023 11:23 •  Информатика

Напишите программу, которая вычисляет сумму цифор только трехзначных чисел

Ответ:
kisik404
kisik404
23.07.2020 08:16
Var a,b,c,d:integer;
begin
writeln('Введите число:');
readln(a);
if (a div 1000=0) and (a div 100>0)  then begin
b:=a div 100;
c:=a div 10 - (a div 100) * 10;
d:=a - (a div 10)*10;writeln(b+c+d);
end
else writeln('Вы ввели не трехзначное число.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?