В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Olegggg04
Olegggg04
27.08.2020 09:48 •  Информатика

Написать программу на паскале,которая выведет на экран те строки из текстового файла, которые являются палиндромами. имя файла вводить с клавиатуры.

Ответ:
vano1399
vano1399
22.07.2020 09:00
Program proga_25_3;
var
 A: text;
s,p : string; 
i:integer;
 f:boolean;
begin 
  write('Введите имя и путь к файлу   '); 
  read(p); 
 assign(A, p); 
 reset(A);   
while not eof(A) do   
 begin       
 readln(A,s);                  
for i:=1 to length(s) div 2 do       
  if s[i]=s[length(s)-i+1] then          
 f:=true        
 else         
begin       
 f:=false;       
 break;       
 end;     
 if f then      
  writeln (S);   
 end;   
 close(A);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?