В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лилия3510
Лилия3510
15.05.2023 22:30 •  Информатика

Составьте программу, которая формирует массив из 15 случайных целых чисел, принадлежащих промежутке [-20;20] вычислять сумму положительных

Ответ:
gfdehk
gfdehk
11.11.2020 20:13

На паскале:

const

 n=15;

var

 a: array [1..n] of integer;

 sum,i:integer;

begin

 randomize;

 sum:=0;

 for i:=1 to n do

   begin

     a[i]:=random(41)-20;

     write(a[i]:4);

     if a[i]>0 then

       sum:=sum+a[i];

   end;

 writeln;

 write('sum: ',sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?