В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Olgarezkova
Olgarezkova
08.03.2022 21:15 •  Информатика

1. составьте программу к : «на яблоне было х яблок. в первый день с яблони упало а яблок. каждый следующий день опадало в 2 раза больше яблок, чем в предыдущий. сколько яблок останется через k дней? ».

Ответ:
george39
george39
22.07.2020 07:55
Паскаль:

var
x, k, a, i: integer;

begin
writeln('Введите количество яблок');
readln(x);
writeln('Введите количество дней');
readln(k);
writeln('Введите количество яблок, которое упало в 1 день');
readln(a);

for i:=1 to k do begin
x:=x-a;
a:=a*2;
end;

writeln(inttostr(x));
sleep(3000);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?