В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lgolar
lgolar
04.02.2021 03:52 •  Информатика

Дано действительное число х. напишите программу для вычисления: числа х, округлённого до ближайшего целого числа х без дробных цифр

Ответ:
Sova551
Sova551
02.10.2020 13:19
В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления:
Если число положительное, то при величине его дробной части меньше 0.5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица. Если число отрицательное, то при абсолютной величине его дробной части меньше 0.5, она просто отбрасывается, если больше - из числа вычитается единица.
А функция Trunc возвращает целую часть числа.

var
  p:real;
begin
  Write('Введите число: '); Read(p);
  Writeln('Округленное значение: ',Round(p),', целая часть: ',Trunc(p))
end.

Тестовое решение:
Введите число: -12.74
Округленное значение: -13, целая часть: -12

Введите число: 12.93
Округленное значение: 13, целая часть: 12

Введите число: 9.4323
Округленное значение: 9, целая часть: 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?