В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
амина74726
амина74726
20.03.2022 20:19 •  Информатика

Написать программу посчитывающую в массиве сумму элементов меньших 0 ,их количество и средее значение

Ответ:
SabZero55
SabZero55
21.07.2020 23:53
У меня получилась такая программка:

uses Crt;
const n=15;
type Vec=array [1..n] of integer ;
var i, SumOtr, ColOtr: integer;
    A: Vec ;
begin
ClrScr;
Randomize;
SumOtr:=0;
ColOtr:=0;
WriteLn (' Massiv A: ');
for i:=1 to n do
    begin
       A[i]:=-10+random(20);
       if A[i]<0  then
          begin
             SumOtr:=SumOtr+A[i];
             ColOtr:=ColOtr+1;
          end;
       Write (A[i]:4);
    end;
WriteLn;
WriteLn('ColOtr = ', ColOtr);
WriteLn('SumOtr = ', SumOtr);
WriteLn('SredOtr = ', SumOtr/ColOtr:4:2);
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?