В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
davidpolovnev
davidpolovnev
26.10.2020 17:54 •  Информатика

Написать программу. даны 2 числа a и b. найти среднее арифметическое всех чисел кратных 3 из интервала [a,b].

Ответ:
KennyPro
KennyPro
02.10.2020 12:58
var
  i, j, a, b: integer;
  s: real;
begin
  write('Введите a: '); readln(a);
  write('Введите b: '); readln(b);
  for i := a to b do
    if (i mod 3) = 0 then
    begin
      s := s + i;
      inc(j);
    end;
  s := s / j;
  writeln('ответ: ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?